Summer Sale Discount Flat 70% Offer - Ends in 0d 00h 00m 00s - Coupon code: 70diswrap

Splunk SPLK-1002 Dumps

Page: 1 / 31
Total 313 questions

Splunk Core Certified Power User Exam Questions and Answers

Question 1

Which knowledge object is used to normalize field names to comply with the Splunk Common Information Model (CIM)?

Options:

A.

Field alias

B.

Event types

C.

Search workflow action

D.

Tags

Question 2

When should the regular expression mode of Field Extractor (FX) be used? (select all that apply)

Options:

A.

For data cleanly separated by a space, a comma, or a pipe character.

B.

For data in a CSV (comma-separated value) file.

C.

For data with multiple, different characters separating fields.

D.

For unstructured data.

Question 3

What is needed to define a calculated field?

Options:

A.

Eval expression

B.

Data model

C.

Event type

D.

Regular expression

Question 4

Which of the following statements describe data model acceleration? (select all that apply)

Options:

A.

Root events cannot be accelerated.

B.

Accelerated data models cannot be edited.

C.

Private data models cannot be accelerated.

D.

You must have administrative permissions or the accelerate_dacamodel capability to accelerate a data model.

Question 5

Which of the following search control will not re-rerun the search? (Select all that apply.)

Options:

A.

zoom out

B.

selecting a bar on the timeline

C.

deselect

D.

selecting a range of bars on the timelines

Question 6

The transaction command allows you to __________ events across multiple sources

Options:

A.

duplicate

B.

correlate

C.

persist

D.

tag

Question 7

Marty has multiple data sources that contain fields with IP Address values. What knowledge object should he use to normalize the fields so his data is CIM compliant?

Options:

A.

Event type

B.

Field alias

C.

Field extraction

D.

Tag

Question 8

Which of the following is a feature of the Pivot tool?

Options:

A.

Creates lookups without using SPL.

B.

Data Models are not required.

C.

Creates reports without using SPL

D.

Datasets are not required.

Question 9

Information needed to create a GET workflow action includes which of the following? (select all that apply.)

Options:

A.

A name of the workflow action

B.

A URI where the user will be directed at search time.

C.

A label that will appear in the Event Action menu at search time.

D.

A name for the URI where the user will be directed at search time.

Question 10

Which type of workflow action sends field values to an external resource (e.g. a ticketing system)?

Options:

A.

POST

B.

Search

C.

GET

D.

Format

Question 11

When using timechart, how many fields can be listed after a by clause?

Options:

A.

because timechart doesn't support using a by clause.

B.

because _time is already implied as the x-axis.

C.

because one field would represent the x-axis and the other would represent the y-axis.

D.

There is no limit specific to timechart.

Question 12

When using | timchart by host, which filed is representted in the x-axis?

Options:

A.

date

B.

host

C.

time

D.

-time

Question 13

There are several ways to access the field extractor. Which option automatically identifies data type, source type, and sample event?

Options:

A.

Event Actions > Extract Fields

B.

Fields sidebar > Extract New Field

C.

Settings > Field Extractions > New Field Extraction

D.

Settings > Field Extractions > Open Field Extraction

Question 14

In this search, __________ will appear on the y-axis. SEARCH: sourcetype=access_combined status!=200 | chart count over host

Options:

A.

status

B.

host

C.

count

Question 15

Which of the following are required to create a POST workflow action?

Options:

A.

Label, URI, search string.

B.

XMI attributes, URI, name.

C.

Label, URI, post arguments.

D.

URI, search string, time range picker.

Question 16

This function of the stats command allows you to identify the number of values a field has.

Options:

A.

max

B.

distinct_count

C.

fields

D.

count

Question 17

Which of the following data models are included in the Splunk Common Information Model (CIM) add-on? (select all that apply)

Options:

A.

User permissions

B.

Alerts

C.

Databases

D.

Email

Question 18

Which of the following actions can the eval command perform?

Options:

A.

Remove fields from results.

B.

Create or replace an existing field.

C.

Group transactions by one or more fields.

D.

Save SPL commands to be reused in other searches.

Question 19

Data models are composed of one or more of which of the following datasets? (select all that apply)

Options:

A.

Transaction datasets

B.

Events datasets

C.

Search datasets

D.

Any child of event, transaction, and search datasets

Question 20

Which of the following statements about calculated fields in Splunk is true?

Options:

A.

Calculated fields cannot be chained together to create more complex fields

B.

Calculated fields can be chained together to create more complex fields.

C.

Calculated fields can only be used in dashboards.

D.

Calculated fields can only be used in saved reports.

Question 21

For the following search, which command would further filter for only IP addresses present more than five times?

Options:

A.

index=games I stats count as IP_count by IP B. | where IP_count > 5

B.

index=games | search IP_Count > 5

C.

index=games | where IP > 5

D.

index=games I search IP > 5

Question 22

Which of the following fields should be normalized using the Splunk Common Information Model (CIM) based on their relationship?

Options:

A.

src_ip, dest_ip

B.

src_ip, source_ip

C.

index, sourcetype

D.

src_ip, src_port

Question 23

It is mandatory for the lookup file to have this for an automatic lookup to work.

Options:

A.

Source type

B.

At least five columns

C.

Timestamp

D.

Input filed

Question 24

What does the following search do?

as

Options:

A.

Creates a table of the total count of users and split by corndogs.

B.

Creates a table of the total count of mysterymeat corndogs split by user.

C.

Creates a table with the count of all types of corndogs eaten split by user.

D.

Creates a table that groups the total number of users by vegetarian corndogs.

Question 25

To identify all of the contributing events within a transaction that contains at least one REJECT event, which syntax is correct?

Options:

A.

Index-main | REJECT trans sessionid

B.

Index-main | transaction sessionid | search REJECT

C.

Index=main | transaction sessionid | whose transaction=reject

D.

Index=main | transaction sessionid | where transaction=reject’’

Question 26

Which of the following statements describe the search below? (select all that apply)

Index=main I transaction clientip host maxspan=30s maxpause=5s

Options:

A.

Events in the transaction occurred within 5 seconds.

B.

It groups events that share the same clientip and host.

C.

The first and last events are no more than 5 seconds apart.

D.

The first and last events are no more than 30 seconds apart.

Question 27

The Field Extractor (FX) is used to extract a custom field. A report can be created using this custom field. The created report can then be shared with other people in the organization. If another person in the organization runs the shared report and no results are returned, why might this be? (select all that apply)

Options:

A.

Fast mode is enabled.

B.

The dashboard is private.

C.

The extraction is private-

D.

The person in the organization running the report does not have access to the index.

Question 28

When creating a search workflow action, what character(s) are used as a placeholder for field values in the search string?

Options:

A.

*

B.

()

C.

$

D.

#

Question 29

Which group of users would most likely use pivots?

Options:

A.

Users

B.

Architects

C.

Administrators

D.

Knowledge Managers

Question 30

What functionality does the Splunk Common Information Model (CIM) rely on to normalize fields with different names?

Options:

A.

Macros.

B.

Field aliases.

C.

The rename command.

D.

CIM does not work with different names for the same field.

Question 31

Which of the following searches can be saved as an event type?

Options:

A.

index=server_516 sourcetype=BETA_201 code=S51 [ | inputlookup servercode.csv append=t ]

B.

index=server_516 sourcetype=BETA_201 code=551

C.

index=server_516 sourcetype=BETA_201 code=551 | stats count by code

D.

index=server_516 sourcetype=BETA_201 code=551 | where code > 200

Question 32

Which of the following statements is true about the root dataset of a data model?

Options:

A.

It can contain transforming commands as long as it is a root search dataset.

B.

It will automatically contain knowledge objects associated with the base search.

C.

It must contain the transaction command if it is a root transaction dataset.

D.

It can only contain a base search with no transforming commands.

Question 33

Which of the following can be saved as an event type?

Options:

A.

index=server_48 sourcetype=BETA_881 code=220

B.

index=server_48 sourcetype=BETA_881 code=220 | stats count by code

C.

index=server_48 sourcetype=BETA_881 code=220 | inputlookup append=t servercode.csv

D.

index=server_48 sourcetype=BETA_881 code=220 | stats where code > 220

Question 34

After manually editing; a regular expression (regex), which of the following statements is true?

Options:

A.

Changes made manually can be reverted in the Field Extractor (FX) UI.

B.

It is no longer possible to edit the field extraction in the Field Extractor (FX) UI.

C.

It is not possible to manually edit a regular expression (regex) that was created using the Field Extractor (FX) UI.

D.

The Field Extractor (FX) UI keeps its own version of the field extraction in addition to the one that was manually edited.

Question 35

What is the Splunk Common Information Model (CIM)?

Options:

A.

The CIM is a prerequisite that any data source must meet to be successfully onboarded into Splunk.

B.

The CIM provides a methodology to normalize data from different sources and source types.

C.

The CIM defines an ecosystem of apps that can be fully supported by Splunk.

D.

The CIM is a data exchange initiative between software vendors.

Question 36

How is a macro referenced in a search?

Options:

A.

By using the macroname command.

B.

By using the macro command.

C.

By enclosing the macro name in backtick characters (‘).

D.

By enclosing the macro name in single-quote characters (‘).

Question 37

How do event types help a user search their data?

Options:

A.

Event types can optimize data storage.

B.

Event types improve dashboard performance.

C.

Event types improve search performance.

D.

Event types categorize events based on a search string.

Question 38

Which tool uses data models to generate reports and dashboard panels without using SPL?

Options:

A.

Visualization tab

B.

Pivot

C.

Datasets

D.

splunk CIM

Question 39

Which of the following statements are true for this search? (Select all that apply.) SEARCH: sourcetype=access* |fields action productld status

Options:

A.

is looking for all events that include the search terms: fields AND action AND productld AND status

B.

users the table command to improve performance

C.

limits the fields are extracted

D.

returns a table with 3 columns

Question 40

What is required for a macro to accept three arguments?

Options:

A.

The macro's name ends with (3).

B.

The macro's name starts with (3).

C.

The macro's argument count setting is 3 or more.

D.

Nothing, all macros can accept any number of arguments.

Question 41

A user wants to convert numeric field values to strings and also to sort on those values.

Which command should be used first, the eval or the sort?

Options:

A.

It doesn't matter whether eval or sort is used first.

B.

Convert the numeric to a string with eval first, then sort.

C.

Use sort first, then convert the numeric to a string with eval.

D.

You cannot use the sort command and the eval command on the same field.

Question 42

This clause is used to group the output of a stats command by a specific name.

Options:

A.

Rex

B.

As

C.

List

D.

By

Question 43

When creating an event type, which is allowed in the search string?

Options:

A.

Tags

B.

Joins

C.

Subsearches

D.

Pipes

Question 44

The fields sidebar does not show________. (Select all that apply.)

Options:

A.

interesting fields

B.

selected fields

C.

all extracted fields

Question 45

Selected fields are displayed ______each event in the search results.

Options:

A.

below

B.

interesting fields

C.

other fields

D.

above

Question 46

What happens to the original field name when a field alias is created?

Options:

A.

The original field name is not affected by the creation of a field alias.

B.

The original field name is replaced by the field alias within the index.

C.

The original field name is italicized to indicate that it is not an alias.

D.

The original field name still exists in the index but is not visible to the user at search time.

Question 47

When performing a regular expression (regex) field extraction using the Field Extractor (FX), what happens when the require option is used?

Options:

A.

The regex can no longer be edited.

B.

The field being extracted will be required for all future events.

C.

The events without the required field will not display in searches.

D.

Only events with the required string will be included in the extraction.

Question 48

Which of the following is the correct way to use the data model command to search field in the data model within the web dataset?

Options:

A.

| datamodel web search | filed web *

B.

| Search datamodel web web | filed web*

C.

| datamodel web web field | search web*

D.

Datamodel=web | search web | filed web*

Question 49

When using transaction, what is the default maximum span between events?

Options:

A.

Unlimited

B.

1h

C.

1m

D.

1d

Question 50

Which of the following searches would return a report of sales by product-name?

Options:

A.

chart sales by product_name

B.

chart sum(price) as sales by product_name

C.

stats sum(price) as sales over product_name

D.

timechart list(sales), values(product_name)

Question 51

Which of the following knowledge objects can reference field aliases?

Options:

A.

Calculated fields, lookups, event types, and tags.

B.

Calculated fields and tags only.

C.

Calculated fields and event types only.

D.

Calculated fields, lookups, event types, and extracted fields.

Question 52

Complete the search, …. | _____ failure > successes

Options:

A.

Search

B.

Where

C.

If

D.

Any of the above

Question 53

__________ datasets can be added to root dataset to narrow down the search

Options:

A.

parent

B.

extracted

C.

event

D.

child

Question 54

Which of the following statements about tags is true?

Options:

A.

Tags are case insensitive.

B.

Tags can make your data more understandable.

C.

Tags are created at index time.

D.

Tags are searched by using the syntax tag :: < fieldname > .

Question 55

A field alias is created where field1—fieid2 and the Overwrite Field Values checkbox is selected.

What happens if an event only contains values for fieid1?

Options:

A.

field2 values are removed from the events.

B.

field1 and field2 values are merged.

C.

field2 values are unchanged.

D.

field2 values are replaced with the value of the field1.

Question 56

What is the purpose of the fillnull command?

Options:

A.

Replace empty values with a specified value.

B.

Create a new field based on the values in an existing field.

C.

Rename a specific field in the search results.

D.

Replace all values in a specific field with a default value.

Question 57

Consider the following search:

index=web sourcetype=access_corabined

The log shows several events that share the same jsesszonid value (SD462K101O2F267). View the events as a group.

From the following list, which search groups events by jSSESSIONID?

Options:

A.

index=web sourcetype=access_combined I transaction JSESSZONID I search SD462K101C2F267

B.

index=web sourcetype=access_combined SD462K101O2F267 | table JSESSIONID

C.

index=web sourcetype=access_combined | highlight JSESSIONID | search SD462K101O2F267

D.

index=web sourcetype=access_combined JSESSTONID < SD4€2K101O2F267 >

Question 58

Which of the following statements best describes a macro?

Options:

A.

A macro is a method of categorizing events based on a search.

B.

A macro is a way to associate an additional (new) name with an existing field name.

C.

A macro is a portion of a search that can be reused in multiple place

D.

A macro is a knowledge object that enables you to schedule searches for specific events.

Question 59

Field aliases are used to __________ data

Options:

A.

clean

B.

transform

C.

calculate

D.

normalize

Question 60

Which of the following statements describe the search string below?

| datamodel Application_State All_Application_State search

Options:

A.

Evenrches would return a report of sales by state.

B.

Events will be returned from the data model named Application_State.

C.

Events will be returned from the data model named All_Application_state.

D.

No events will be returned because the pipe should occur after the datamodel command

Question 61

Which of the following searches will show the number of categoryld used by each host?

Options:

A.

Sourcetype=access_* |sum bytes by host

B.

Sourcetype=access_* |stats sum(categorylD. by host

C.

Sourcetype=access_* |sum(bytes) by host

D.

Sourcetype=access_* |stats sum by host

Question 62

What type of command is eval?

Options:

A.

Streaming in some modes

B.

Report generating

C.

Distributable streaming

D.

Centralized streaming

Question 63

This function of the stats command allows you to return the middle-most value of field X.

Options:

A.

Median(X)

B.

Eval by X

C.

Fields(X)

D.

Values(X)

Question 64

Which of the following searches would create a graph similar to the one below?

as

Options:

A.

index_internal seourcetype=Savesplunker | fields sourcetype, status | transaction status maxspan-id | start count states

B.

index_internal seourcetype=Savesplunker | fields sourcetype, status | transaction status maxspan-id | chart count states by -time

C.

index_internal seourcetype=Savesplunker | fields sourcetype, status | transaction status maxspan-id | timechart count by status

D.

None of these searches would generate a similart graph.

Question 65

How are event types different from saved reports?

Options:

A.

Event types cannot be used to organize data into categories.

B.

Event types include formatting of the search results.

C.

Event types can be shared with Splunk users and added to dashboards.

D.

Event types do not include a time range.

Question 66

Which of the following expressions could be used to create a calculated field called gigabytes?

Options:

A.

eval sc_bytes(1024/1024)

B.

| eval negabytes=sc_bytes(1024/1024)

C.

megabytes=sc_bytes(1024/1024)

D.

sc_bytas(1024/1024)

Question 67

When creating a POST workflow action, what can a user define as the POST arguments?

Options:

A.

Static text only

B.

A combination of static text and field value pairs

C.

A combination of field value pairs and the search query

D.

Field value pairs only

Question 68

Which of the following can be saved as an event type?

Options:

A.

index=server_539 sourcetype=BETA_713 code=439 | stats count by code

B.

index=server_539 sourcetype=BETA_713 code=439 | where code > 200

C.

index=server_539 sourcetype=BETA_713 code=439 [ | inputlookup servercode.csv append=t ]

D.

index=server_539 sourcetype=BETA_713 code=439

Question 69

Which of the following statements about tags is true?

Options:

A.

Tags are case insensitive.

B.

Tags are created at index time.

C.

Tags can make your data more understandable.

D.

Tags are searched by using the syntax tag: : < fieldneme >

Question 70

What does the fillnull command do in this search?

index=main sourcetype=http:log | fillnull value="Unknown" src

Options:

A.

Set the values of the src field to null when it is "Unknown".

B.

Set all fields that are null to "Unknown".

C.

Set the values of the src field to "Unknown" if it is null.

D.

Set all fields with the value of "Unknown" to null.

Question 71

A user wants to retrieve IP address information. How should the URI be specified to configure a GET workflow action?

Question 72

These kinds of charts represent a series in a single bar with multiple sections

Options:

A.

Multi-Series

B.

Split-Series

C.

Omit nulls

D.

Stacked

Question 73

What is the relationship between data models and pivots?

Options:

A.

Data models provide the datasets for pivots.

B.

Pivots and data models have no relationship.

C.

Pivots and data models are the same thing.

D.

Pivots provide the datasets for data models.

Question 74

Where are the results of eval commands stored?

Options:

A.

In a field.

B.

In an index.

C.

In a KV Store.

D.

In a database.

Question 75

When using the transaction command, what is the assigned timestamp for each of the resulting transactions?

Options:

A.

The timestamp of the event search time execution.

B.

The timestamp of the earliest event.

C.

The difference between the earliest and latest event.

D.

The timestamp of the most recent event.

Question 76

In what order arc the following knowledge objects/configurations applied?

Options:

A.

Field Aliases, Field Extractions, Lookups

B.

Field Extractions, Field Aliases, Lookups

C.

Field Extractions, Lookups, Field Aliases

D.

Lookups, Field Aliases, Field Extractions

Question 77

Which of the following data model are included In the Splunk Common Information Model (CIM) add-on? (select all that apply)

Options:

A.

Alerts

B.

Email

C.

Database

D.

User permissions

Question 78

In the Field Extractor, when would the regular expression method be used?

Options:

A.

When events contain JSON data.

B.

When events contain comma-separated data.

C.

When events contain unstructured data.

D.

When events contain table-based data.

Question 79

To create a tag, which of the following conditions must be met by the user?

Options:

A.

Identify at least one field:value pair.

B.

Have the Power role at a minimum.

C.

Be able to edit the sourcetype the tag applies to.

D.

Must have the tag capability associated with their user role.

Question 80

What is a limitation of searches generated by workflow actions?

Options:

A.

Searches generated by workflow action cannot use macros.

B.

Searches generated by workflow actions must be less than 256 characters long.

C.

Searches generated by workflow action must run in the same app as the workflow action.

D.

Searches generated by workflow action run with the same permissions as the user running them.

Question 81

The macro weekly_sales (2) contains the search string:

index—games I eval Product Sales = $price$ $AmountS01d$

Which of the following will return results?

Options:

A.

‘weekly_sales(3.99, 10) '

B.

‘weekly_sales($3.99$, $10$)

C.

'weekly_sales (3.99, 10)

D.

‘weekly_sales(3)

Question 82

What does the fillnull command replace null values with, if the value argument is not specified?

Options:

A.

0

B.

N/A

C.

NaN

D.

NULL

Question 83

Which of the following workflow actions can be executed from search results? (select all that apply)

Options:

A.

GET

B.

POST

C.

LOOKUP

D.

Search

Question 84

Which of the following statements describe the Common Information Model (CIM)? (select all that apply)

Options:

A.

CIM is a methodology for normalizing data.

B.

CIM can correlate data from different sources.

C.

The Knowledge Manager uses the CIM to create knowledge objects.

D.

CIM is an app that can coexist with other apps on a single Splunk deployment.

Question 85

Which delimiters can the Field Extractor (FX) detect? (select all that apply)

Options:

A.

Tabs

B.

Pipes

C.

Spaces

D.

Commas

Question 86

A user wants to create a new field alias for a field that appears in two sourcetypes.

How many field aliases need to be created?

Options:

A.

One.

B.

Two.

C.

It depends on whether the original fields have the same name.

D.

It depends on whether the two sourcetypes are associated with the same index.

Question 87

By default, how is acceleration configured in the Splunk Common Information Model (CIM) add-on?

Options:

A.

Turned off

B.

Turned on

C.

Determined automatically based on the sourcetype.

D.

Determined automatically based on the data source.

Question 88

What are the names of the top-level datasets in data models?

Options:

A.

Core datasets

B.

Root datasets

C.

Root indexes

D.

Core indexes

Question 89

A space is an implied _____ in a search string.

Options:

A.

OR

B.

AND

C.

()

D.

NOT

Question 90

Which knowledge Object does the Splunk Common Information Model (CIM) use to normalize data. in addition to field aliases, event types, and tags?

Options:

A.

Macros

B.

Lookups

C.

Workflow actions

D.

Field extractions

Question 91

Use this command to use lookup fields in a search and see the lookup fields in the field sidebar.

Options:

A.

inputlookup

B.

lookup

Question 92

Which workflow action method can be used the action type is set to link?

Options:

A.

GET

B.

PUT

C.

Search

D.

UPDATE

Question 93

Which statement is true?

Options:

A.

Pivot is used for creating datasets.

B.

Data model are randomly structured datasets.

C.

Pivot is used for creating reports and dashboards.

D.

In most cases, each Splunk user will create their own data model.

Page: 1 / 31
Total 313 questions