Pre-Summer Sale Discount Flat 70% Offer - Ends in 0d 00h 00m 00s - Coupon code: 70diswrap

CrowdStrike CCSE-204 Dumps

Page: 1 / 6
Total 62 questions

CrowdStrike Certified SIEM Engineer Questions and Answers

Question 1

What is the recommended order of the three required activities to build an efficient CQL query?

Options:

A.

Filter > Format > Aggregate

B.

Filter > Aggregate > Format

C.

Format > Filter > Aggregate

D.

Aggregate > Filter > Format

Question 2

You need to provide a colleague the appropriate role to allow for configuration of connectors and creation of SOAR automations in Next-Gen SIEM.

Which role will provide these permissions while also maintaining least privilege?

Options:

A.

NG SIEM Security Lead

B.

NG SIEM Analyst

C.

Falcon Security Lead

D.

Custom role

Question 3

Which command helps visualize in real time whether sources and sinks are working properly in the Log Collector?

Options:

A.

journalctl -u logscale-collector

B.

logscale-collector monitor

C.

logscale-collector check

D.

logscale-collector --status

Question 4

You notice a larger than expected ingest delay from one of your high-volume streaming log collectors.

Which setting should you increase on the log collector to improve performance?

Options:

A.

Amount of available disk space

B.

Available source throughput

C.

Number of concurrent requests a sink is using

D.

Default memory queue size

Question 5

You are performing a search query using data from the Falcon Sensor and third-party data connectors.

Which Advanced Event Search data source should you choose?

Options:

A.

All

B.

Falcon

C.

Third-party

D.

Custom

Question 6

You are reviewing logs and find that the content appears as one large block of text within the @rawstring field for incoming firewall logs. The other expected structured fields are empty.

What is the cause of this issue?

Options:

A.

The parser was incorrect

B.

The ingestion token is invalid

C.

The sink was overloaded

D.

The timestamp format is incorrect

Question 7

Which Falcon LogScale Collector mode keeps the log source configuration stored locally on the collector host instead of centrally in Fleet Management?

Options:

A.

full

B.

central

C.

localConfig

D.

collectorOnly

Question 8

What dashboard presents a view of third-party data ingestion over the past 30 days?

Options:

A.

Sensor Usage Dashboard

B.

Sensor Subscription Dashboard

C.

Falcon Flex Dashboard

D.

Next-Gen SIEM Connector Dashboard

Question 9

An internal security team identified a small number of high-risk users. They ask you to create an app that will monitor these users and trigger an alert when specific suspicious behavior is detected.

Which Falcon feature should you use to develop this app?

Options:

A.

Falcon QueryBuilder

B.

Falcon Spotlight

C.

Falcon Foundry

D.

Charlotte AI

Question 10

Following the principle of least privilege, which is the appropriate role to grant a Falcon Next-Gen SIEM user the permissions to read case data and write XDR data while denying the permission to write case templates?

Options:

A.

NG SIEM Security Lead

B.

NG SIEM Analyst – Read Only

C.

NG SIEM Analyst

D.

NGSIEM Administrator

Question 11

Which CQL statement below includes correct placement of the AND statements and the pipe symbol?

Options:

A.

#sourcefile="jobfilename" AND stdout=/\[[\+]\] / | groupBy([hostname], function=collect([hostname,stdout] )) AND stdout != "" AND stdout != "* No artifacts *" | select([hostname,stdout])

B.

#sourcefile="jobfilename" | stdout=/\[[\+]\] / | groupBy([hostname], function=collect([hostname,stdout] )) | stdout != "" AND stdout != "* No artifacts *" AND select([hostname,stdout])

C.

#sourcefile="jobfilename" AND stdout=/\[[\+]\] / | groupBy([hostname], function=collect([hostname,stdout] )) | stdout != "" AND stdout != "* No artifacts *" | select([hostname,stdout])

D.

#sourcefile="jobfilename" | stdout=/\[[\+]\] / AND groupBy([hostname], function=collect([hostname,stdout] )) AND stdout ! = "" | stdout != "* No artifacts *" | select([hostname,stdout])

Question 12

When setting up a data connector, which parser can be used to transform incoming data into searchable events that trigger detections in Next-Gen SIEM?

Options:

A.

CrowdStrike Parsing Standard (CPS) compliant parser

B.

Charlotte AI-generated parser

C.

VMWare ESXI parser

D.

Linux syslog parser

Question 13

You are onboarding a log source that includes a timestamp with a different timezone.

How should you address any time parsing errors that occur?

Options:

A.

Clone the parser and manually apply the timezone parameter

B.

Adjust the log source to reflect the correct timezone before sending logs

C.

Clone the parser and change the timestamp field name

D.

Clone the parser and drop the timestamp field, use ingesttimestamp instead

Question 14

An event has the following fields:

as

Which CQL query will output the frequency of a unique set of ComputerName, UserName, CommandLine?

Options:

A.

#event_simpleName = ProcessRollup2 FileName = ssh.exe CommandLine = /\s-R\s.+\s-p/ | table([ComputerName, UserName, CommandLine]) | count()

B.

#event_simpleName = ProcessRollup2

| FileName = ssh.exe

| CommandLine = /\s-R\s.+\s-p/

| table([ComputerName, UserName, CommandLine], function=count())

C.

#event_simpleName = ProcessRollup2

| FileName = ssh.exe

| CommandLine = /\s-R\s.+\s-p/

| groupBy([ComputerName, UserName, CommandLine], function=count())

D.

#event_simpleName = ProcessRollup2 FileName = ssh.exe CommandLine = /\s-R\s.+\s-p/ | groupBy([ComputerName, UserName, CommandLine])

Question 15

You need to ingest data from a custom internal application hosted on-prem. The application writes logs to a file on a syslog server.

Which data connector would you use?

Options:

A.

Google Cloud Pub / Sub Data Connector

B.

HTTP Event Connector

C.

Amazon S3 Data Connector

D.

Azure Virtual Machines Data Connector

Question 16

As a Next-Gen SIEM Engineer, you are responsible for managing and tuning correlation rules to improve the detection of potential security incidents. One of your correlation rules is designed to detect multiple failed login attempts that are followed by a successful login within a short time frame.

Which step would you take to tune this correlation rule to reduce false positives while maintaining its effectiveness?

Options:

A.

Increase the time window for detecting multiple failed login attempts to capture more data

B.

Add a condition to exclude known trusted IP addresses from triggering the rule

C.

Decrease the threshold for the number of failed login attempts required to trigger the rule

D.

Remove the condition for a successful login to simplify the rule

Question 17

You are reviewing a lookup file to determine whether an event was successfully parsed during ingestion.

Which metadata field indicates the event’s parsing status?

Options:

A.

@ingesttimestamp

B.

@rawstring

C.

@error_msg

D.

@event_parsed

Question 18

Which default parser would you use to parse the log event below?

Jan 15 14:22:07 host1 sshd[1234]: Failed login

Options:

A.

Key-value

B.

JSON

C.

Regex

D.

Syslog

Page: 1 / 6
Total 62 questions